What platform would you run Quetoo on if it was on Steam?:

updated this morning, but still compile error macosx

May 18, 2009 - 22:30pm


I noticed there were similar compile errors on ubuntu that have since been resolved, so I updated from the repo a few minutes ago, but I am still getting this error on macosx.

make all-recursive
Making all in src
Making all in .
/bin/sh ../libtool --tag=CC --mode=compile gcc -DHAVE_CONFIG_H -I. -I.. -I/usr/X11/include/ -I/opt/local/include/ -pipe -Wall -Wmissing-prototypes -Wmissing-declarations -Werror -Wdeclaration-after-statement -g -I/opt/local/include/SDL -D_GNU_SOURCE=1 -D_THREAD_SAFE -g -O2 -MT libimages_la-images.lo -MD -MP -MF .deps/libimages_la-images.Tpo -c -o libimages_la-images.lo `test -f 'images.c' || echo './'`images.c
gcc -DHAVE_CONFIG_H -I. -I.. -I/usr/X11/include/ -I/opt/local/include/ -pipe -Wall -Wmissing-prototypes -Wmissing-declarations -Werror -Wdeclaration-after-statement -g -I/opt/local/include/SDL -D_GNU_SOURCE=1 -D_THREAD_SAFE -g -O2 -MT libimages_la-images.lo -MD -MP -MF .deps/libimages_la-images.Tpo -c images.c -fno-common -DPIC -o .libs/libimages_la-images.o
In file included from /opt/local/include/jpeglib.h:24,
from images.c:44:
/opt/local/include/jconfig.h:12:1: error: "HAVE_STDLIB_H" redefined
In file included from shared.h:25,
from common.h:26,
from images.h:27,
from images.c:23:
../config.h:35:1: error: this is the location of the previous definition
make[3]: *** [libimages_la-images.lo] Error 1
make[2]: *** [all-recursive] Error 1
make[1]: *** [all-recursive] Error 1
make: *** [all] Error 2


It looks like a config error, should I try commenting out the definition in config.h and make again?



May 22, 2009 - 01:10am

Hm, that's really weird. Everything that uses Autoconf is going to generate a config.h that will likely define HAVE_STDLIB_H. So it seems to me like the libjpeg port on OSX has a bug.

I guess the safest hack for now would be to do something like:

#define HAVE_STDLIB_H 1

Inside of quake2world/config.h. Hop on IRC if that doesn't work out. Actually, hop on IRC anyway to get some games going :)

July 06, 2009 - 10:54am

Hello jdolan,

yesterday I also tried to install Quake2World on my Mac the way its described on this page. I encountered exactly the same error message as the starter of this thread. So it seems to be a general problem.

Since I do not know C I have no idea what to do to correct the error.

If you find a solution could you please post it here so anyone else with mac can profit from it?