What platform would you run Quetoo on if it was on Steam?:

[SOLVED] quake2world.exe - Application Error

March 16, 2009 - 20:30pm

I did an rsync yesterday, it worked fine. I did updated today, and I get a dialog box popping up saying:

quake2world.exe - Application Error

The application failed to initialize properly (0xc0000022). Click on OK to terminate the application.

Just letting you know..

March 17, 2009 - 13:22pm

Over the weekend I committed a rather significant changeset that replaces the Quake2 sound system with SDL_mixer. This required the introduction of several new dependencies (SDL_mixer, vorbis, smpeg, etc..). I'll see if anyone else is seeing this. Is there any info in stdout.txt or stderr.txt?

March 18, 2009 - 22:53pm

It's empty, does it log there by default?

March 23, 2009 - 15:44pm

Could you try today's build? Are you able to start the game from gdb.exe?

March 28, 2009 - 22:36pm

I've been doing an rsync every other day or less with the same error.

I'm a unix junkie, but my gaming PC is my only windows box. Didn't know gdb was of any use in the windows world.

I'm not a C coder, and it doesn't seem like this helps much, so let me know if I'm doing this wrong.

$ gdb quake2world.exe
GNU gdb (cygwin-special)
Copyright (C) 2008 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law. Type "show copying"
and "show warranty" for details.
This GDB was configured as "i686-pc-cygwin"...
(gdb) run
Starting program: /cygdrive/c/Program Files/quake2world/quake2world.exe
[New thread 1660.0x360]
gdb: unknown target exception 0xc0000022 at 0x7c96478e

April 05, 2009 - 12:36pm

... with my 6 weeks old version of q2w (I was out of town for a while) and got rid of it by deleting the old installation and downloading/installing the latest win32 build. I have no idea why simply running update.bat didn't fix it, tried that many times and nothing happened. But now it works so I don't care too much...

April 19, 2009 - 19:12pm

I blew away the q2w dir and did a rsync from scratch.

Awesome. Thanks spirit.